What about keeping the changes completely mechanical and semantically the same for this large patch and fixing the issues separately ?
Why this change ? I can see that this does not read, but what about keeping this change completely mechanical ?
Looks like this might have been incorrect. Maybe add the author to that patch as an FYI ?
this used to be: if (max(DstAlign, SrcAlign) < 4), ie.g. if (DstAlign < Align(4) && SrcAlign < Align(4))
This is not NFC.
Can you do that in a separate patch ?
This might have been a bug, but again, let's fix it separately.
this should be ( || )
This function has so many arguments (and I actually added another one downstream in the CHERI fork), would it make sense to introduce a struct for some of them (similar to struct MemOp` in TargetLowering?