- User Since
- Sep 4 2015, 4:18 PM (301 w, 20 h)
Tue, Jun 8
Thu, Jun 3
rebase after macro name change
Sorry, forgot to commit this. Will do so now.
Sun, May 30
I believe all remaining issues were addressed in the latest version.
Sat, May 29
Apr 28 2021
- Drop check for i8 as suggested by @arsenm
- Add addSymbolReloc() as suggested
Split the addend checking into a separate review, this now only include fixes for incorrect addends plus the DynamicReloc refactoring.
Thanks for the review, will update shortly.
address review feedback
I will commit this based on the previous approval in 1 month (1st June) unless there are any further comments.
Apr 27 2021
Superseded by D101279
Maybe adding AbortOnInvalidReduction should be a separate commit, but the overall diff looks good to me.
Apr 23 2021
Maybe OutputSection::checkDynRelAddends() should be moved to a separate patch and this one just does the DynamicReloc refactoring that fixes ppc64-abs64-dyn.s and got32-i386-pie-rw.s with -z rela.
@MaskRay would that make reviewing the patch easier?
Apr 22 2021
Apr 21 2021
Drop unrelated changes
- fix tests on platforms without 128-floating point types (e.g. x86 macOS)
- fix doc comment
Rebase on top of D100489
Use an enum instead of the highly overloaded useSymVA. Hopefully the logic is easier to follow now.
Apr 19 2021
I'm not sure it's a good idea to remove the -ast-dump=json option. While this is -cc1 option, there do seem to be external consumers based on a quick search for "-ast-dump=json". Keeping it would also reduce some of the test churn.
Address review feedback from @jhenderson
Apr 15 2021
Fix the failing amd64 test
Breaks lld/test/ELF/x86-64-tlsdesc-gd.s, will investigate.
- remove debug RUN: line
Hopefully the new test is better?
- simplify test case
Apr 14 2021
Apr 9 2021
- fix pre-processing test after output changes
- Fix Windows path regex
If there are no further comments, I will commit this early next week.
Add a test
Apr 8 2021
I just merged this commit into our CHERI fork and noticed some failing tests due to round tripping:
We add some additional CodeGenOptions and LangOptions, but are not including those in the generated command line.
Drop chunk that is no longer necessary
Add the raw triple prefix for programs (but prefer the adjusted triple) and always use the adjusted triple for libraries.
Should hopefully address the feedback from @joerg.
No longer necessary