This is to address the inconsistency between FLT_ROUNDS_ and SET_ROUNDING SDAG node. Rename FLT_ROUNDS_ to GET_ROUNDING and add llvm.get.rounding intrinsic to replace flt.rounds.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Unit Tests
Unit Tests
Event Timeline
Comment Actions
Thank you for working on this!
Is there any reason why we should keep the old intrinsic?
Comment Actions
I'm not clear on the general policy, but for x86 we tend to provide bc of old intrinsics/sigtaures via AutoUpgrade.cpp, supposedly only for a few releases but tbh we remove them very rarely....
Comment Actions
In case any user outside of clang references it (although I believe no), we can deprecate it and remove after a few releases.
libcxxabi/test/test_demangle.pass.cpp | ||
---|---|---|
12917 ↗ | (On Diff #482381) | Demangling tests should not be updated. |
llvm/docs/LangRef.rst | ||
24567 | Can drop this note now. | |
llvm/lib/IR/AutoUpgrade.cpp | ||
916 | This needs a test in llvm/test/Bitcode. Create a bitcode file using flt.rounds prior to this change, and then test llvm-dis on it. |
Can drop this note now.