Use getFunctionEntryPointSymbol whenever possible to enclose the implementation detail and reduce duplicate logic.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/include/llvm/Target/TargetLoweringObjectFile.h | ||
---|---|---|
250 | the code should be never come to here. maybe report an fatal error maybe better. |
llvm/include/llvm/Target/TargetLoweringObjectFile.h | ||
---|---|---|
250 | Current code won't come here. But I think returning a nullptr have more benefit than just report_fatal_error. Sometimes, we could write code that relying on it being return nulltpr on Targets that does not support it (instead of relying on target query). |
llvm/lib/CodeGen/TargetLoweringObjectFileImpl.cpp | ||
---|---|---|
2156 | I think getNameWithPrefix appends, meaning that NameStr.push_back('.') before calling it will do what we need without using operator+ below. |
the code should be never come to here. maybe report an fatal error maybe better.