This patch adds the assembly/disassembly for the following instruction:
INT:
SMAX (multiple and single vector): Multi-vector signed maximum by vector. (multiple vectors): Multi-vector signed maximum. SMIN (multiple and single vector): Multi-vector signed minimum by vector. (multiple vectors): Multi-vector signed minimum. UMAX (multiple and single vector): Multi-vector unsigned maximum by vector. (multiple vectors): Multi-vector unsigned maximum. UMIN (multiple and single vector): Multi-vector unsigned minimum by vector. (multiple vectors): Multi-vector unsigned minimum. SRSHL (multiple and single vector): Multi-vector signed rounding shift left by vector. (multiple vectors): Multi-vector signed rounding shift left. URSHL (multiple and single vector): Multi-vector unsigned rounding shift left by vector. (multiple vectors): Multi-vector unsigned rounding shift left.
FP:
FMAX (multiple and single vector): Multi-vector floating-point maximum by vector. (multiple vectors): Multi-vector floating-point maximum. FMAXNM (multiple and single vector): Multi-vector floating-point maximum number by vector. (multiple vectors): Multi-vector floating-point maximum number. FMIN (multiple and single vector): Multi-vector floating-point minimum by vector. (multiple vectors): Multi-vector floating-point minimum. FMINNM (multiple and single vector): Multi-vector floating-point minimum number by vector. (multiple vectors): Multi-vector floating-point minimum number.
The reference can be found here:
https://developer.arm.com/documentation/ddi0602/2022-09
It also updates ADD and SQDMULH
Depends on: D135563
Should this be SMAX_VG4_4Z4Z? If yes then you'll need to check all new defs in this patch because I've seen this potentially incorrect naming several times.
Whilst mentioning consistency the choice of whether to use _VG# seems arbitrary or perhaps I'm misinterpreting it's meaning. For example SRSHL_2Z2Z looks like it should have _VG2 but doesn't. That said, given we specify the register types within the instructions (i.e. _2Z2Z) I'm wondering if most all the _VG# usages are redundant?
Redundancy is likely a question for later but I do think you should be naming the instructions consistently.