Page MenuHomePhabricator

[Driver] -p: change from unused warning to error for most targets
ClosedPublic

Authored by MaskRay on Nov 17 2022, 7:42 PM.

Details

Summary

AIX and OpenBSD seem to use -p. For most targets (at least FreeBSD and Linux),
-p is legacy (GCC freebsd has a warning). We don't want the uses to grow, so
making -p an alias for -pg is not recommended. I think the uses are small.

Diff Detail

Event Timeline

MaskRay created this revision.Nov 17 2022, 7:42 PM
MaskRay requested review of this revision.Nov 17 2022, 7:42 PM
Herald added a project: Restricted Project. · View Herald TranscriptNov 17 2022, 7:42 PM
Herald added a subscriber: cfe-commits. · View Herald Transcript
mgorny accepted this revision.Dec 2 2022, 10:51 AM
mgorny added a subscriber: mgorny.

LGTM

This revision is now accepted and ready to land.Dec 2 2022, 10:51 AM

Thanks! I think this is better landing before AIX -p patches for clarity, so I am landing it now...