Page MenuHomePhabricator

[VP] Rename SDNode of vp.fptrunc from VP_FP_ROUND to VP_FP_TRUNCATE
AbandonedPublic

Authored by eopXD on Sep 25 2022, 6:11 AM.

Details

Summary

The current naming is asymmetric to naming of vp.trunc (VP_TRUNCATE).
It may also become easily mistaken when we have vp.round in the future.

Diff Detail

Event Timeline

eopXD created this revision.Sep 25 2022, 6:11 AM
eopXD requested review of this revision.Sep 25 2022, 6:11 AM

The name was chosen to be consistent with ISD::FP_ROUND. There is no ISD::FP_TRUNCATE. The naming issue you mention already exists for ISD::FP_ROUND and ISD::FROUND. Consistency with non-VP opcodes is more important.

eopXD abandoned this revision.Sep 25 2022, 10:07 AM

I see. This revision is not needed then.