The current naming is asymmetric to naming of vp.trunc (VP_TRUNCATE).
It may also become easily mistaken when we have vp.round in the future.
The name was chosen to be consistent with ISD::FP_ROUND. There is no ISD::FP_TRUNCATE. The naming issue you mention already exists for ISD::FP_ROUND and ISD::FROUND. Consistency with non-VP opcodes is more important.