This is patch is part of a series to introduce an Alignment type.
See this thread for context: http://lists.llvm.org/pipermail/llvm-dev/2019-July/133851.html
See this patch for the introduction of the type: https://reviews.llvm.org/D64790
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/lib/CodeGen/MachineOperand.cpp | ||
---|---|---|
1059 | The outer Align looks unnecessary. | |
llvm/lib/Target/PowerPC/PPCISelLowering.cpp | ||
13653–13654 | This is not an NFC. Should this be isAligned() ? | |
13724–13725 | ditto |
llvm/lib/Target/PowerPC/PPCISelLowering.cpp | ||
---|---|---|
13653–13654 | isAligned currently works the other way around, here is the definition inline bool isAligned(Align Lhs, uint64_t SizeInBytes) { return SizeInBytes % Lhs.value() == 0; } Rewritten with isAligned, !(MMO->getAlignment()%16 gives isAligned(Align(16), MMO->getAlign().value()), this is not very readable. Now !(A % 16) means that A should be a multiple of 16. So although it is not a straightforward it is NFC. | |
13724–13725 | same here |
The outer Align looks unnecessary.