The "getField" method is a bit confusing considering we also have a
"getFieldName" method. Instead, use "getFieldDecl" rather than
"getField".
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Paths
| Differential D147743
[Clang][NFC] Rename methods/vars to reflect their real usage ClosedPublic Authored by void on Apr 6 2023, 2:36 PM.
Details Summary The "getField" method is a bit confusing considering we also have a
Diff Detail
Event TimelineThis revision is now accepted and ready to land.Apr 18 2023, 6:34 AM This revision was landed with ongoing or failed builds.Apr 18 2023, 1:48 PM Closed by commit rGb51a03e1bbe7: [Clang][NFC] Rename methods/vars to reflect their real usage (authored by void). · Explain Why This revision was automatically updated to reflect the committed changes.
Revision Contents
Diff 514731 clang-tools-extra/clangd/FindTarget.cpp
clang-tools-extra/clangd/XRefs.cpp
clang/include/clang/AST/Expr.h
clang/include/clang/Sema/Designator.h
clang/include/clang/Tooling/Refactoring/RecursiveSymbolVisitor.h
clang/lib/AST/Expr.cpp
clang/lib/Index/IndexBody.cpp
clang/lib/Sema/SemaCodeComplete.cpp
clang/lib/Sema/SemaInit.cpp
clang/lib/Sema/TreeTransform.h
clang/lib/Serialization/ASTReaderStmt.cpp
clang/lib/Serialization/ASTWriterStmt.cpp
clang/lib/Tooling/Refactoring/Rename/USRLocFinder.cpp
clang/tools/libclang/CIndex.cpp
|
nit