This one required more changes than ideal due to overlapping generated name
with different return types. Changed getIndexingMaps to getIndexingMapsArray to
move it out of the way/highlight that it returns (more expensively) a
SmallVector and uses the prefixed name for the Attribute.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
mlir/lib/Dialect/Linalg/Transforms/SparseTensorRewriting.cpp | ||
---|---|---|
153 ↗ | (On Diff #445183) | This file is being refactored out of Linalg, see https://reviews.llvm.org/D129910 |
mlir/lib/Dialect/Linalg/Transforms/SparseTensorRewriting.cpp | ||
---|---|---|
153 ↗ | (On Diff #445183) | SG, luckily change is minimal, so easy to move (I could rename this independent of accessor prefixing too, but the only reason for review is to make folks aware of the rename and in case there is feedback for better name, unfortunately interfaces end up coupling changes). |