Remove usages of asserting vector getters in Type in preparation for the
VectorType refactor. The existence of these functions complicates the
refactor while adding little value.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/lib/IR/ConstantFold.cpp | ||
---|---|---|
1999 | Please split out. | |
llvm/lib/IR/Constants.cpp | ||
320 | Please split this off into a separate patch. I think "return false" is actually correct, but it probably makes sense to assert the vector is a ConstantAggregateZero or an UndefValue. | |
llvm/lib/IR/Function.cpp | ||
1079 | Does VectorType::getNumElements() not return unsigned? | |
llvm/lib/IR/Verifier.cpp | ||
4682 | Please don't mix functional and non-functional changes. |
llvm/lib/IR/Function.cpp | ||
---|---|---|
1079 | it's uint64_t. getVectorNumElements() was unsigned, it just did the conversion |
llvm/lib/IR/Constants.cpp | ||
---|---|---|
1900 | Please don't mix functional and non-functional changes. | |
1914 | Please don't mix functional and non-functional changes. | |
llvm/lib/IR/Instructions.cpp | ||
2950 | Please don't mix functional and non-functional changes. | |
2969 | Please don't mix functional and non-functional changes. | |
llvm/lib/IR/Verifier.cpp | ||
2830 | Please don't mix functional and non-functional changes. | |
3348 | Please don't mix functional and non-functional changes. | |
4663 | Please don't mix functional and non-functional changes. |
llvm/lib/IR/Constants.cpp | ||
---|---|---|
231 | Please don't add new isScalable checks in this patch. (Here, and other places in this file.) |
llvm/lib/IR/ConstantFold.cpp | ||
---|---|---|
748 | ConstantFoldSelectInstruction can take non-vector inputs. This should cause test failures. (Somehow I thought you fixed this in an earlier revision, but I could be mistaken.) |
llvm/lib/IR/ConstantFold.cpp | ||
---|---|---|
748 | I'll fix it |
llvm/lib/IR/ConstantFold.cpp | ||
---|---|---|
750 | Unnecessary cast<> |
ConstantFoldSelectInstruction can take non-vector inputs. This should cause test failures. (Somehow I thought you fixed this in an earlier revision, but I could be mistaken.)