This function looks more like fromSliceCoord to me, where "v" is the coordinate in the slice view. Am I right?
iv = slice_iv * stride + offset? I am not sure whether we should also add a period in this case?
Related to the above, this looks like toSliceCoord to me.
slice_iv = (iv - offset)/stride?
I don't see FileCheck test for this pattern, can we add such test?
Do we really need this lib?
We should avoid having the second part repeat the first part, maybe even try to avoid having the same NZ values in two different positions.
Hmmm, yeah, updated.
No, I confirmed that it is folded.
But it does not really matter, I manually skip the check anyway in the following revision.
This is a nop right now (the check test is added in the dynamic slice revision, which actually implements it).
so what happens if you do "the right thing" here already?
Using numbers and code is hard to read.
First, coord >= ...
needs its own comment, or be moved some place else?
TODO, not "probably" ;-)
I remember that it crashed, as there is no fields for dimSliceAttr in specifier yet.