Page MenuHomePhabricator

[mlir] Rename FunctionOpInterface::getBody to getFunctionBody
ClosedPublic

Authored by rriddle on Sep 30 2022, 7:03 PM.

Details

Summary

This is much more explicit, and prevents annoying conflicts with op
specific accessors (which may have a different contract). This is similar
to the past rename of getType -> getFunctionType,

Fixes #58030

Diff Detail

Event Timeline

rriddle created this revision.Sep 30 2022, 7:03 PM
Herald added a project: Restricted Project. · View Herald TranscriptSep 30 2022, 7:03 PM
rriddle requested review of this revision.Sep 30 2022, 7:03 PM
lattner accepted this revision.Oct 1 2022, 9:38 AM

Thank you, this is very helpful!

This revision is now accepted and ready to land.Oct 1 2022, 9:38 AM
bondhugula added inline comments.
mlir/test/lib/Pass/TestPassManager.cpp
159

op.getFunctionBody()

This revision was automatically updated to reflect the committed changes.
rriddle marked an inline comment as done.