Barrier is a simple operation that takes no arguments and returns
nothing, but implies a side effect (synchronization of all threads)
All of these files are missing top-level file comments.
Why is this header necessary?
Is OpImplementation.h necessary here?
These should use // style comments. Please refer to other similar files for examples.
Need an extra space here.
Only OpenMPDialect.h seems necessary here.
Use using namespace ... instead, (with explicit scoping when necessary)
See other files for examples.
nit: Use getDialectNamespace instead of hardcoding the string.
I moved this include to the .cpp file. If I don't have it at all I get linker errors related to some missing function definitions.
I've changed this to ompDialect to be consistent with the namespace name change. Let me know if there's a preferred name for this though.
While that is interesting on its own, my comment was not targeted at variable naming conventions but rather towards how we commonly, and even in MLIR, treat "names". "OpenMP" is (used as) a proper name, doing anything to it seems problematic, e.g., we cannot properly search for it. We also have ample of precedence, e.g. GPU, LLVM, SPIRV, .... at least I haven't seen gPU, lLVM, or sPIRV.
That sounds fine to me.
I don't remember that we ever fully resolved this(adding OpenMP Dialect). Can you make a ping on llvm.discourse.group to make sure?
MLIR -> LLVM now
nit: Missing punctuation at the end of the line.
The original RFC was sent to mlir google groups in December. (https://groups.google.com/a/tensorflow.org/d/msg/mlir/SCerbBpoxng/bVqWTRY7BAAJ)
I have now posted this RFC in discourse.