Traditionally, clang-tidy uses the term check, and the analyzer uses checker, but in the very early years, this wasn't the case, and code originating from the early 2010's still incorrectly refer to checkers as checks.
This patch attempts to hunt down most of these, aiming to refer to checkers as checkers, but preserve references to callback functions (like checkPreCall) as checks.
One thing that is still off in this context (haha) however is CheckerContext, which is also, in this sense, an incorrect name: it isn't a context of a checker, but rather a single callback. Shall I change that to CheckContext?