Note: WIP patch 1/3 to go with a RFC for the device RTL design.
This NFCI patch includes the following cleanup steps:
- Merge the state-queue.h and state-queuei.h as the separation was artificial, and the files had a cyclic include dependence anyway.
- Remove the now obsolete state-queuei.h.
- Adjust the code according to the LLVM coding style, especially wrt. variable and method names.
- Change the names of types to be generic, or just less NVPTX specific.
- Wrap CUDA specific calls into __kmpc_impl_XXX functions and define them in an own target_impl.h file.
I think it is better to mark it as Cuda, not C/C++, since it contains some Cuda specific constructs.