Thanks for following up! Adding some thoughts to consider.
Worth indicating which of these produce a value per iteration, per part, per lane?
Worth adding that this induction controls the vector loop, by comparing it with the vector trip count?
Worth adding that this is done by introducing an independent vector header phi?
So perhaps a more consistent name would be VPScalarIntOrFpInductionRecipe?
So perhaps a more consistent name would be VPPointerInductionRecipe?
Updated the wording, but kept the name for now to just reflect the current realities in the documentation, thanks!
I am planning to handle the non-widening case by using derived IV + scalar steps in future patches.
Ship it, thanks!
Add [NFC] to title?
Relate to recent IV recipe patches in commit message?
nit: worth emphasizing - "a [single] scalar PHI"
nit: "vector phis for each part" >> "a vector PHI per-part", to be more consistent with above and below?
"Produces a single scalar value per iteration"
"vector phis" - better use either "phi" or "PHI" consistently.
Worth adding that vector phis are produced per-part and scalar values per-lane?