- User Since
- Jan 23 2017, 12:28 AM (228 w, 6 d)
Fri, Jun 11
This patch needs to implement VPIntrinsic::getDeclarationForParams.
This needs to be rebased onto recent upstream.
In order to pass all unittest then, this patch needs an implementation in VPIntrinsic::getDeclarationForParams.
Thu, Jun 10
Sure. I will commit this.
Make clang-format happy
Removed unused HasRoundingMode, etc functions.
Wed, Jun 9
As discussed on the call, maybe rename llvm.experimental.vp.vector.splice to llvm.experimental.vp.splice.. the "vector" is implied
Tue, Jun 8
Mon, Jun 7
Any input for this patch? Happy for people to step up for a LGTM ;-)
Are we ok with this one?
I am ready to LGTM this. Any blockers?
Thu, May 27
+1 for folding variables into ifs while you're at it.
Tue, May 25
Apart from the nit, this looks good to me. @rogfer01 ?
Wed, May 19
- Simplified w/o ShortTypeVec
Tue, May 18
May 12 2021
May 11 2021
FYI. There is a biweekly syncup call on VP (Tue, 3pm CET, next: 2021-05-11)
With D93534 out of the way, we should have cleared all hurdles for this one. Where do we stand, comments, LGTMs?
May 4 2021
May 3 2021
Apr 30 2021
Apr 26 2021
- Fixed LangRef copy pasta bugs.
- Formatting in VPIntrinsics.def
Apr 23 2021
Apr 21 2021
Apr 20 2021
The unit test changes in this patch depend on the cleanup work done in D93534 . Please have a look at that one too!
Apr 19 2021
- worked through reviewers' comments (thx!)
Apr 16 2021
Thanks. I am not too excited to moderate an open Discord server. Better invite people individually / on the call.
Apr 14 2021
This LGTM on a conceptual level from the standpoint of SX-Aurora.
I guess @fhahn would be the right person to weigh in on the VPlan changes.
When it comes to the actual patches for this RFC, it'd help to upstream the VectorBuilder class. It allows you to emit VP code without having to juggle with VP intrinsics.
Apr 13 2021
Apr 8 2021
Apr 6 2021
Mar 30 2021
- Addressed super nit
Mar 29 2021
Can we split this up into a patch with only the intrinsics and a second patch with SelectionDAG?
We should use the align(N) attribute on pointers to convey the alignment. That's what we do in the LLVM for SX-Aurora stack (https://github.com/sx-aurora-dev/llvm-project/blob/683f41073689262a8a493cce7caba13bbccea56c/llvm/test/CodeGen/VE/Packed/vp_load_packed.ll#L80) . I'd say that the alignment parameter in the pre-existing masked.load/store simply predates that attribute.
And yes, setting alignment is something that the VPBuilder or what's-it-called-after-bikeshedding would take care of for you.
Mar 4 2021
Modernize tests, replace undef -> poison
Addressed @ctetreau 's comments. Thx!
Mar 3 2021
Feb 24 2021
Jan 28 2021
Jan 19 2021
Jan 12 2021
NFC. Usage of Optional. Rebased onto committed D93709 .
Jan 11 2021
Title typo: 'isntert'
Jan 8 2021
NFC. Rebased. Use variable name Opcode instead of OC.
Can we accept this patch? In the end, it is a strict improvement over the existing one.. and it is "just" a unittest..
This is one of those patches that has the potential to linger on without review for 1Y+ .. let me know if there is anything i can do to get this reviewed, as it really helps with bringing good vector architecture (long SIMD) support to LLVM. Thanks.
We want somebody that has reviewed VP patches before to review the VP bits of this (getters, really). @kaz7 takes care of the VE parts. Thanks!
This now depends on D93687 - the build_vector lowering causes introduces more instances of insert_vector_elt.
- Rebased onto main.
- insert_vector_elt tests trigger vbrd code path because lowering of build_vector to insert_vector_elt is gone (D93759).
Jan 5 2021
|& -> 2>&1 |
- Hopefully attached signext to all args in tests this time
- Adressed comments
You might want to fix the typo in the title before committing this.