This is an archive of the discontinued LLVM Phabricator instance.

[NFC] Rename enable-strict-reductions to force-ordered-reductions
ClosedPublic

Authored by david-arm on Aug 2 2021, 4:16 AM.

Details

Summary

I'm renaming the flag because a future patch will add a new
enableOrderedReductions() TTI interface and so the meaning of this
flag will change to be one of forcing the target to enable/disable
them. Also, since other places in LoopVectorize.cpp use the word
'Ordered' instead of 'strict' I changed the flag to match.

Diff Detail

Event Timeline

david-arm created this revision.Aug 2 2021, 4:16 AM
david-arm requested review of this revision.Aug 2 2021, 4:16 AM
Herald added a project: Restricted Project. · View Herald TranscriptAug 2 2021, 4:16 AM
sdesmalen accepted this revision.Aug 2 2021, 4:43 AM

Makes sense to me, this also aligns the naming of the other force flags that override the target's cost-model.

llvm/lib/Transforms/Vectorize/LoopVectorize.cpp
337

nit: Force the vectorization of loops with in-order (strict) FP reductions.
(also: vectorization in American spelling)

This revision is now accepted and ready to land.Aug 2 2021, 4:43 AM