Part of the code related to ds_read/ds_write ISel is refactored, and the
corresponding comment is re-written for better readability, which would help
while implementing any future ds_read/ds_write ISel related modifications.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/lib/Target/AMDGPU/SIISelLowering.cpp | ||
---|---|---|
1415–1416 | "related hardware bug" - no idea what this is referring to |
llvm/lib/Target/AMDGPU/SIISelLowering.cpp | ||
---|---|---|
1415–1416 | This is actually referring to - https://github.com/llvm/llvm-project/blob/6c0a1ed3a94ff34e6d9500cdfd04858b1a6f72aa/llvm/lib/Target/AMDGPU/AMDGPU.td#L175 The boolean function hasLDSMisalignedBug() is used to track it. |
llvm/lib/Target/AMDGPU/DSInstructions.td | ||
---|---|---|
843–847 | Please just merge these two foreach loops. Same for the other pairs of foreach loops which are now adjacent. | |
880 | I think something like "do not select ds_read_b128/ds_write_b128 for unaligned accesses" would be more accurate. We still select them for aligned accesses. Also "at lower alignments" doesn't make much sense now you have changed the first half of the comment not to mention any particular alignment. |
Please just merge these two foreach loops. Same for the other pairs of foreach loops which are now adjacent.