Page MenuHomePhabricator

[NFC] [LLParser] Renaming LLParser routines to satisfy LLVM coding style
ClosedPublic

Authored by alok on Oct 27 2020, 9:07 AM.

Details

Summary

This patch does not change any functionality.

Renaming of functions in LLParser.cpp/LLParser.h is done to satisfy coding style.

This was needed while D89218 was done. clang-tidy was unhappy over newly added function LLParser::ParseDIGenericSubrange.


/mnt/disks/ssd0/agent/llvm-project/llvm/lib/AsmParser/LLParser.cpp:4599:16: warning: invalid case style for function 'ParseDIGenericSubrange' [readability-identifier-naming]
bool LLParser::ParseDIGenericSubrange(MDNode *&Result, bool IsDistinct) {

^~~~~~~~~~~~~~~~~~~~~~

parseDiGenericSubrange

This function is implicitly defined using macro as

#define HANDLE_SPECIALIZED_MDNODE_LEAF(CLASS) \

if (Lex.getStrVal() == #CLASS)                                               \
 return Parse##CLASS(N, IsDistinct);

#include "llvm/IR/Metadata.def"

Change here requires changes at other places as well.

Diff Detail

Event Timeline

alok created this revision.Oct 27 2020, 9:07 AM
Herald added a project: Restricted Project. · View Herald Transcript
alok requested review of this revision.Oct 27 2020, 9:07 AM
alok edited the summary of this revision. (Show Details)
djtodoro accepted this revision.Oct 27 2020, 9:20 AM

It was huge. Thanks.

This revision is now accepted and ready to land.Oct 27 2020, 9:20 AM
This revision was landed with ongoing or failed builds.Oct 27 2020, 8:29 PM
This revision was automatically updated to reflect the committed changes.
alok added a comment.Oct 27 2020, 10:31 PM

It was huge. Thanks.

Thanks a lot for review.