This patch renames some mapping keys:
AbbrOffset -> DebugAbbrevOffset
AddrSize -> AddressSize
AbbrCode -> AbbrevCode
Higuoxing on Aug 5 2020, 3:33 AM.Authored by
Sorry about the delay, I was OOO.
I think that making these consistent with the DWARF spec is a good idea. It's true that this makes DebugAbbrevOffset a bit longish. I could also live with just AbbrevOffset, but I think the longer version is also fine for two reasons:
Okay, LGTM. I don't mind either way, and I suspect with the offset field becoming optional soon, it's unlikely to appear frequently, so the verbosity is a non-issue then.