The concept of the ActionManager acts as a sort of "Hub" that can receive
various types of action and dispatch them to a set of registered handlers.
One handler will handle the action or it'll cascade to other handlers.
This model does not really fit the current evolution of the Action tracing
and debugging: we can't foresee a good case where this behavior compose with
the use-case behind the handlers. Instead we simplify it with a single
callback installed on the Context.
The naming here feels much too general for something specific to actions, I'd rather have this be an explicitly named API.
Also, why "dispatch"? instead of something like "execute" or something more aligned with how actions define the verbage.