Fixed the misleading comment.
Returns if ...
Returns true if ...
Please fix the 80 column spillovers. Although this "Returns if ..." construction is used pervasively and isn't actually incorrect, it can be a bit confusing. "if this ..." was being used as a noun for the bool value.
Please fix the commit title - it's itself broken.
Improve the Comment -> "Improve doc comments for several methods returning bools"
This will have to be wrapped.