Given that it's a C++20 addition, I think that you don't need to use _LIBCPP_CONSTEXPR and directly write constexpr. This remarks concerns other usages below.
It would be more readable to call it __false_value or alike, because __value seems too generic.
Why Using Capital Letters?
What about unifying a bit static assert messages to match other in libc++?
static_assert(is_trivially_copyable<_Tp>::value, "std::atomic<Tp> requires that 'Tp' be a trivially copyable type"); static_assert(__is_cpp17_move_insertable<allocator_type>::value, "The specified type does not meet the requirements of Cpp17MoveInsertible"); static_assert(__bitop_unsigned_integer<_Tp>::value, "__rotl requires unsigned");
Maybe something like "<numbers> header requires a floating-point type" or mentioning the corresponding concept (floating_point)?
It should be written as int(201907), otherwise it won't work on Python3.
It seems that you formatted a bit too much. I think that you should avoid formatting auto-generated files.