This patch adds a checker to detect patterns of the following form:
auto IntermediateVar = foo(); return (IntermediateVar == 1);
and suggests to turn them into:
return (foo() == 1);
The reasoning behind this checker is that this kind of pattern is useless and lowers readability as long as the return statement remains rather short.
The idea of this checker was suggested to me by Sylvestre Ledru.
Please upload patches with full context (-U999999)