Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
mlir/lib/Conversion/GPUCommon/GPUToLLVMConversion.cpp | ||
---|---|---|
284 | probably add a create to avoid the upper case start createSDDMM..... | |
289–290 | This should start with a lower case, e.g. assertSparseLtEnvHandleSizeCallBuilder, | |
316 | SpMM would be more in line with others | |
1777 | remove this empty line for consistency with surrounding code | |
mlir/lib/ExecutionEngine/CudaRuntimeWrappers.cpp | ||
484–485 | isn't it getting a bit expensive to add this call just for an assert that does not even run in prod builds? |
mlir/lib/ExecutionEngine/CudaRuntimeWrappers.cpp | ||
---|---|---|
484–485 | none of these asserts seem runtime specific, right? So, can't we make this a static_assert(....) |
mlir/lib/Conversion/GPUCommon/GPUToLLVMConversion.cpp | ||
---|---|---|
266 | keep this lowercase, or use createSpMMBufferSizeCallBuilder | |
278 | create... | |
1429 | we probably want to put these magic constants as symbolic constants, but okay to do that later | |
mlir/lib/ExecutionEngine/CudaRuntimeWrappers.cpp | ||
494 | return; not needed | |
535 | is that expected by the lib? if so, please add a comment here |
keep this lowercase, or use createSpMMBufferSizeCallBuilder