Page MenuHomePhabricator

[analyzer][NFC] Use idiomatic classof instead of isKind
ClosedPublic

Authored by steakhal on May 16 2022, 10:35 AM.

Details

Summary
  • Rename isKind() to classof() to follow the llvm style RTTI.
  • Take SVal by-value instead of reference.
  • Mark classof public.

Diff Detail

Event Timeline

steakhal created this revision.May 16 2022, 10:35 AM
Herald added a project: Restricted Project. · View Herald TranscriptMay 16 2022, 10:35 AM
steakhal requested review of this revision.May 16 2022, 10:35 AM
Herald added a project: Restricted Project. · View Herald TranscriptMay 16 2022, 10:35 AM
Herald added a subscriber: cfe-commits. · View Herald Transcript
martong accepted this revision.May 17 2022, 1:53 AM

LGTM

This revision is now accepted and ready to land.May 17 2022, 1:53 AM
xazax.hun accepted this revision.May 17 2022, 10:19 AM
This revision was automatically updated to reflect the committed changes.