Page MenuHomePhabricator

[flang][nfc] Update the description of `!fir.coordinate_of`
ClosedPublic

Authored by awarzynski on Dec 17 2021, 3:49 AM.

Details

Summary

This change was suggested in one of the comments for
https://reviews.llvm.org/D115333. Basically, the following usage is
valid, but the current wording suggests otherwise:

%1 = fir.coordinate_of %a, %k : (!fir.ptr<!fir.array<5x15x25xi32>>, index) -> !fir.ref<!fir.array<5x15xi32>>

Diff Detail

Event Timeline

awarzynski created this revision.Dec 17 2021, 3:49 AM
Herald added a project: Restricted Project. · View Herald TranscriptDec 17 2021, 3:49 AM
awarzynski requested review of this revision.Dec 17 2021, 3:49 AM
Herald added a project: Restricted Project. · View Herald TranscriptDec 17 2021, 3:49 AM
rovka added a comment.Jan 10 2022, 7:14 AM

Maybe we should also add a test for this? I'm not sure if we have anything similar to this upstream.

Maybe we should also add a test for this? I'm not sure if we have anything similar to this upstream.

Good suggestion, will send one in a sec!

Add a test for the newly documented case

rovka accepted this revision.Jan 17 2022, 1:01 AM

LGTM, thanks!

This revision is now accepted and ready to land.Jan 17 2022, 1:01 AM
schweitz accepted this revision.Jan 21 2022, 1:10 PM
This revision was automatically updated to reflect the committed changes.