Rather than passing two bools (next to each other), use a struct instead.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Comment Actions
I like the idea! Could be a little cleaner imo, but shouldn't be a blocker if others don't think so.
lldb/include/lldb/Core/Module.h | ||
---|---|---|
62 | nit: Maybe a name like ModuleFunctionSearchOptions? A bit more verbose but I wasn't sure what ModuleFunctionOptions meant at first. | |
lldb/source/API/SBModule.cpp | ||
401–403 | nit: IMO this looks cleaner, but no big deal: ModuleFunctionOptions function_options = { .include_symbols = true, .include_inlines = true }; |
lldb/source/API/SBModule.cpp | ||
---|---|---|
401–403 | I love designated initializers (this is a nice use) but this is a C++20 feature and so we would be using this as a GNU extension, which might break some builds. godbolt: https://godbolt.org/z/TKMddMrq3 |
nit: Maybe a name like ModuleFunctionSearchOptions? A bit more verbose but I wasn't sure what ModuleFunctionOptions meant at first.