Page MenuHomePhabricator

[OpenMP] [OMPD] Convert the error to warning for enabling OMPD in non-Linux platform
ClosedPublic

Authored by Vigneshbalu on Jul 23 2021, 9:56 AM.

Details

Summary

OMPD is enabled by default on Linux machines and disabled on others.
However, if explicitly enabled it throws an error and exit while configuring.

It is mentioned in Bug: https://bugs.llvm.org/show_bug.cgi?id=51121

This patch, instead of throwing error, disables OMPD support with a warning message, so configuration can continue.

Diff Detail