The instruction to be replaced is recorded in RewritePhi::ExpansionPoint
when collecting RewritePhiSet. We could use the field directly. Besides
this, move Inst closer to its usage.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Unit Tests
Unit Tests
Event Timeline
Comment Actions
There should be no difference for the modification.
In LoopUtils.cpp:1337, the structure RewritePhi is initialized. PN->getIncomingValue(Phi.Ith) should be equal to Phi.ExpansionPoint.
Comment Actions
Personally, I find the existing code much easier to read than the new code. Patch rejected, unless you can justify why this is useful.