Page MenuHomePhabricator

[MLIR] Rename free function `verify` on OffsetSizeAndStrideOpInterface
ClosedPublic

Authored by bondhugula on May 5 2021, 12:51 AM.

Details

Summary

Using a free function verify(<Op>) is error prone. Rename it.

Diff Detail

Event Timeline

bondhugula created this revision.May 5 2021, 12:51 AM
bondhugula requested review of this revision.May 5 2021, 12:51 AM

@bollu Looks like you have a rule to add yourself as a reviewer on every MLIR revision. Was this intended?

ftynse accepted this revision.May 5 2021, 12:59 AM
ftynse added a subscriber: ftynse.

@bollu Looks like you have a rule to add yourself as a reviewer on every MLIR revision. Was this intended?

They have a rule to add themselves as a reviewer on _your_ revisions, and those of some other people - https://reviews.llvm.org/H267.

This revision is now accepted and ready to land.May 5 2021, 12:59 AM
rriddle accepted this revision.May 5 2021, 1:00 AM
rriddle added inline comments.
mlir/include/mlir/Interfaces/ViewLikeInterface.h
32

Could we also move this to the detail namespace?

bondhugula updated this revision to Diff 342972.May 5 2021, 2:47 AM

Move to detail namespace

bondhugula marked an inline comment as done.May 5 2021, 2:50 AM