Adding missing custom builders for AffineVectorLoadOp & AffineVectorStoreOp. In practice, it is difficult to correctly construct these ops without these builders (because the AffineMap is not included at construction time).
Thanks Frank! Sorry, I was OOO last week. Quick comments for now, I'll come back later.
I think in general the rule is to only use auto when it help readability. I personally *try* to only use it for cast/isa/dyn_cast, for other cases where the type is obvious or redundant and for cases where the type is too large (e.g., iterators), but I sometimes abuse it as well :)
|22 ↗||(On Diff #287125)|
These changes seem unrelated to changes on affine.vector_load and affine.vector_store. Please, create a independent differential for them.