This is an archive of the discontinued LLVM Phabricator instance.

[DWARFYAML] Rename checkListEntryOperands() to checkOperandCount(). NFC.

Authored by Higuoxing on Jul 27 2020, 1:34 AM.



This patch renames checkListEntryOperands() to checkOperandCount(), so
that we are able to check DWARF expression operands using the same

Diff Detail

Event Timeline

Higuoxing created this revision.Jul 27 2020, 1:34 AM
Herald added a project: Restricted Project. · View Herald TranscriptJul 27 2020, 1:34 AM
labath accepted this revision.Jul 27 2020, 1:41 AM

Seems reasonable, but I think a better spelling of the name would be checkOperandNumber (no s) -- "check number of operands" vs "check operand number"

This revision is now accepted and ready to land.Jul 27 2020, 1:41 AM
Higuoxing updated this revision to Diff 280882.Jul 27 2020, 6:11 AM

checkOperandsNumber -> checkOperandNumber.

Thanks for reviewing!

jhenderson accepted this revision.Jul 28 2020, 5:55 AM

I'd actually go one step further and call it checkOperandCount. I think checkOperandNumber to me suggests "check the number of the operand X". LGTM, with that tweak.

Higuoxing updated this revision to Diff 281224.Jul 28 2020, 7:18 AM

Address comments.

Higuoxing retitled this revision from [DWARFYAML] Rename checkListEntryOperands() to checkOperandsNumber(). NFC. to [DWARFYAML] Rename checkListEntryOperands() to checkOperandCount(). NFC..Jul 28 2020, 7:18 AM
Higuoxing edited the summary of this revision. (Show Details)

Thanks for reviewing!

jhenderson accepted this revision.Jul 28 2020, 7:22 AM
This revision was landed with ongoing or failed builds.Jul 28 2020, 7:58 AM
This revision was automatically updated to reflect the committed changes.