In an effort to make Process more language agnostic, I removed
GetCPPLanguageRuntime from Process. I'm following up now with an equivalent
change for ObjC.
Details
Diff Detail
- Build Status
Buildable 33143 Build 33142: arc lint + arc unit
Event Timeline
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 | I think it would be nice to just call this Get (and we could have equivalents in the other languages). It makes the uses less verbose and repetitive. | |
source/Plugins/ExpressionParser/Clang/ClangExpressionParser.cpp | ||
515–517 | Why not create a variable? if (const auto *runtime = ObjCLanguageRuntime::Get(*process)) |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 | I like that idea. |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 | I also like this idea. Would you mind if I did that in a follow up? |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 | You're introducing the function in this patch. What's the point in renaming it immediately after that? I can see how renaming GetCPPLanguageRuntime might be a good thing to do in a separate patch, but I don't see a reason to do that with this function |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 | Fair enough. I'll update this patch. |
I think it would be nice to just call this Get (and we could have equivalents in the other languages). It makes the uses less verbose and repetitive.