- User Since
- Nov 12 2014, 1:58 PM (393 w, 2 d)
Apr 27 2022
Compact unwind was developed as a goal to replace the DWARF unwind. Some apps did not work if the OS was missing DWARF unwind, so we kept both for Intel. The binary compatibility issue is non-existent on arm64, but it could be still a thing on x86_64.
If a function cannot be encoded in CU, we need the compiler to emit both (where the CU is a magic value that points to the dwarf unwind info for that function).
Mar 7 2022
I don't run POSIX compliance, somebody just gave me a patch, but yes, good point.
We fixed this in the linker.
Nov 8 2021
Oct 22 2021
Aug 6 2021
May 19 2021
Apr 27 2021
Apr 20 2021
Mar 22 2021
Mar 17 2021
Mar 11 2021
+ Lang, who probably has a better understanding of this, for visibility.
I don't think this should be blocked further, but he might have a chance to comment.
Feb 26 2021
Jan 11 2021
Dec 7 2020
Dec 1 2020
I apologize, but I don't work on this anymore.
Oct 23 2020
Oct 12 2020
I'm sorry, I haven't touched this code in a long time and I don't feel qualified to review it.
Sep 21 2020
Sep 14 2020
Sep 3 2020
This landed in a different form.
Somebody will pick this up, probably in a different form.
I won't have time to look at this in the future.
Aug 27 2020
Aug 24 2020
@labath something I noticed when finding this (and related bugs) is that frame var carries a decent diagnostic
I came to the same conclusion when analyzing https://bugs.llvm.org/show_bug.cgi?id=47257 (but you beat me to the punch).
Aug 21 2020
I think this is fine. @mehdi_amini ?
Aug 14 2020
Aug 11 2020
Aug 5 2020
This is correct to the best of my understanding. Thank you Jason.
yes, this makes sense. We could refine the check in future.
I assume we're still allowing to put the decorator on a test-by-test basis, and that seems the case from what I see.
If so, LG.
Aug 4 2020
LGTM with Saleem's comment addressed.
Aug 3 2020
Jul 30 2020
Reviewed by Jason privately.
Added the check that Jason requested.
Jul 28 2020
Florian, can you take a look?
Jul 22 2020
why? Do you have a testcase?
yeah, I think it's reasonable.