In an effort to make Process more language agnostic, I removed
GetCPPLanguageRuntime from Process. I'm following up now with an equivalent
change for ObjC.
Details
Details
Diff Detail
Diff Detail
- Repository
- rL LLVM
Event Timeline
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 ↗ | (On Diff #203714) | I think it would be nice to just call this Get (and we could have equivalents in the other languages). It makes the uses less verbose and repetitive. |
source/Plugins/ExpressionParser/Clang/ClangExpressionParser.cpp | ||
515 ↗ | (On Diff #203714) | Why not create a variable? if (const auto *runtime = ObjCLanguageRuntime::Get(*process)) |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 ↗ | (On Diff #203714) | I like that idea. |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 ↗ | (On Diff #203714) | I also like this idea. Would you mind if I did that in a follow up? |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 ↗ | (On Diff #203714) | You're introducing the function in this patch. What's the point in renaming it immediately after that? I can see how renaming GetCPPLanguageRuntime might be a good thing to do in a separate patch, but I don't see a reason to do that with this function |
include/lldb/Target/ObjCLanguageRuntime.h | ||
---|---|---|
202 ↗ | (On Diff #203714) | Fair enough. I'll update this patch. |