As mentioned in the comment to https://reviews.llvm.org/D134444, the term tied
is a misnomer in this context and matching sounds much better.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Generally LGTM, thanks for doing this @olegshyshkov !
Let's also see what @mravishankar thinks of this if you don't mind.
mlir/include/mlir/Dialect/Linalg/IR/LinalgInterfaces.td | ||
---|---|---|
422 | getIndexingMapMatchingResult ? Or just getMatchingIndexingMap and rely on polymorphism to "make sense"? | |
873 | This one is definitely "tied" not matching |
Huh, I dont want to bikeshed on naming here. To me getTied* is more intuitive but it might also be familiarity bias. I dont have a strong enough opinion to suggest otherwise.
mlir/include/mlir/Dialect/Linalg/IR/LinalgInterfaces.td | ||
---|---|---|
422 | Used getIndexingMapMatchingResult. Compiler complained about duplicate definition of getMatchingIndexingMap, not sure why polymorphism didn't work. |
LG for sparse code, since this is just a mechanical name change, assuming consensus on the actual name is reached ;-)
getIndexingMapMatchingResult ?
Or just
getMatchingIndexingMap and rely on polymorphism to "make sense"?