Looks good overall.
The way you've written it is fine. Just remove the comment.
Can you just fold the ! and >= into < please
This can be llvm_unreachable
|13 ↗||(On Diff #451667)|
These changes are not significant - it's just update_test_checks choosing a different name for its variables. Could you regenerate the checks for this file first and commit that, and then rebase the current patch?
We need to keep nsw/nuw for add I think.
And it's better to provider alive proof link also.
|726 ↗||(On Diff #451667)|
I think this code want to get better address pattern for load/store. But don't know why we do this before with this comment.
This patch now does not affect integer-round-up-pow2-alignment.ll (since those changes merged via rGf82c55fa082711f520a7359393b483956b69bf08). So, the NFC changes (changes of variable names) that update_test_checks would make don't have to be addressed at this time (I don't think). I did pull those NFC changes to this test out anyway as D132564, but as said I don't think this needs to be messed with just now.