Libomptarget grew out of a project that was originally not in LLVM. As
we develop libomptarget this has led to an increasingly large clash
between the naming conventions used. This patch fixes most of the
variable names that did not confrom to the LLVM standard, that is
VariableName for variables and functionName for functions.
This patch was primarily done using my editor's linting messages, if
there are any issues I missed arising from the automation let me know.