Darwin otool implements this flag as a one-stop solution for displaying bind and rebase info. As I am working on upstreaming chained fixup support this command will be useful to write testcases.
Details
Diff Detail
Event Timeline
Please remember to add new options to the .rst file for llvm-otool.
What's the motivation for adding the option without implementation at this point?
llvm/test/tools/llvm-objdump/MachO/dyld_info.test | ||
---|---|---|
3 | Probably want to add --implicit-check-not={{.}} to catch any new/additional output too. I have a slight personal preference for putting the | at the end of the continued line, to indicate that the next line will be the start of a new command entirely, but I'm not fussed either way. | |
llvm/tools/llvm-objdump/MachODump.cpp | ||
1183–1185 | I don't think we usually bother with these sorts of comments? NB: I haven't bothered looking at the context, so there may be precedent in this file for it. |
What's the motivation for adding the option without implementation at this point?
This patch is part of a series of patches to upstream chained fixup support in MachOObjectFile and I need an implementation of -dyld_info to write tests for that feature. I'm trying break the patch into small pieces to make reviewing easier. With every patch the implementation will become more complete.
llvm/tools/llvm-objdump/MachODump.cpp | ||
---|---|---|
1183–1185 | You're right, the rest of the file also doesn't use them. |
llvm/test/tools/llvm-objdump/MachO/dyld_info.test | ||
---|---|---|
6–7 | Consider also CHECK-NEXT, for full clarity (not needed for test explicitness, thanks to --strict-whitespace, but might make it easier to follow what is the exact output for those not looking at the FileCheck command line). | |
llvm/tools/llvm-objdump/MachODump.cpp | ||
1184 | ||
llvm/tools/llvm-objdump/ObjdumpOpts.td | ||
300–301 |
| |
llvm/tools/llvm-objdump/OtoolOpts.td | ||
44 | You're removing this option from the list of llvm-otool unsupported options, but as I understand it, you've added the option to llvm-objdump, but not llvm-otool. I'm not sure that's quite right? |
llvm/docs/CommandGuide/llvm-objdump.rst | ||
---|---|---|
305 | It looks like all of the llvm-objdump flags today use dashes and not underscores, I know this matches apple's otool instead, but I wonder if it would be better to be consistent with the other ones in this version |
llvm/docs/CommandGuide/llvm-objdump.rst | ||
---|---|---|
305 |
that's the only reason for the name, yes. |
It looks like all of the llvm-objdump flags today use dashes and not underscores, I know this matches apple's otool instead, but I wonder if it would be better to be consistent with the other ones in this version