Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Added some comments.
mlir/include/mlir/Analysis/Presburger/Simplex.h | ||
---|---|---|
165 | Please use triple / doc comments here. | |
mlir/lib/Analysis/Presburger/Simplex.cpp | ||
348 | An assert for i. j not exceeding number of columns would be useful here. | |
453–454 | nit: Did you mean to write "Therefore, no constraint currently..." ? |
mlir/include/mlir/Analysis/Presburger/Simplex.h | ||
---|---|---|
166 | This isn't appropriately named I think because you are allowing one or more variables. I'd prefer not having a default argument here and just naming it appendVariables. It addresses both the naming and makes it explicit for the single var case as well and is as compact. | |
mlir/lib/Analysis/Presburger/Simplex.cpp | ||
483 | You are missing an early: if (count == 0) return |
Thanks for the review!
mlir/include/mlir/Analysis/Presburger/Simplex.h | ||
---|---|---|
166 | I agree with you. I only named it this way for consistency with the insert*Id/append*Id functions that were already present in FlatAffineConstraints (https://github.com/llvm/llvm-project/blob/main/mlir/include/mlir/Analysis/AffineStructures.h#L258-L269). Shall I rename all of these to plural? | |
mlir/lib/Analysis/Presburger/Simplex.cpp | ||
483 | Thanks, added. |
mlir/include/mlir/Analysis/Presburger/Simplex.h | ||
---|---|---|
166 | Oh, I see. We can leave it as is then - was a minor comment. |
Please use triple / doc comments here.