Part of the refactor discussed in:
https://llvm.discourse.group/t/what-is-the-strategy-for-tensor-memref-conversion-bufferization/1938/17
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
It would be great to have more consistency wrt. naming of patterns and passes but this is a step in the right direction.
Left comments for further improvements but those need not be in this change.
mlir/include/mlir/Dialect/Linalg/Transforms/Transforms.h | ||
---|---|---|
801 | Why are these in a header file? | |
807 | Should we aim for a somewhat standardized name for the patterns themselves? Like BufferizeLinalgOpConverter or LinalgOpBufferizer? | |
mlir/include/mlir/Dialect/Shape/Transforms/Passes.h | ||
43–45 | Do we keep the name TypeConversionPatterns? Or should this also become BufferizeOpConversionPatterns? I think the latter is also already in use. | |
mlir/lib/Dialect/Linalg/Transforms/Bufferize.cpp | ||
124–125 | This comment is off. | |
mlir/lib/Dialect/Shape/Transforms/Bufferize.cpp | ||
23 | Could this also be renamed? | |
77 | Here, too. Also scrap the TODO? The BufferizeTypeConverter allows to configure how types should be rewritten. |
mlir/include/mlir/Dialect/Linalg/Transforms/Transforms.h | ||
---|---|---|
807 | @herhut sounds good to me. Maybe we should aim for LinalgOpBufferizer. | |
mlir/include/mlir/Dialect/Shape/Transforms/Passes.h | ||
43–45 | I guess it makes sense to unify these names in a way that they express their association to the internal Bufferize functionality. | |
mlir/lib/Dialect/Linalg/Transforms/Bufferize.cpp | ||
124–125 | This comment is out-of-date and should be adapted. |
Why are these in a header file?