Page MenuHomePhabricator

[libunwind] Split out UnwindInfoSections and dl_iterate_phdr lookup
Needs ReviewPublic

Authored by rprichard on Aug 19 2020, 5:30 PM.


Group Reviewers
Restricted Project

Move the dl_iterate_phdr-based unwind info lookup code into
FrameHeaderCache.hpp and rename it to DlIteratePhdrLookup.hpp.

Remove the unused dl_iterate_cb_data::addressSpace field.

Previously, FrameHeaderCache.hpp was included inside
"namespace libunwind { ... }", and the header recursively included
other headers. Now, DlIteratePhdrLookup.hpp is included in the global
namespace, following the ordinary convention. The lookup code uses the
UnwindInfoSections struct, so break the circular dependency by moving
the struct into its own file.

Diff Detail

Event Timeline

rprichard created this revision.Aug 19 2020, 5:30 PM
Herald added projects: Restricted Project, Restricted Project. · View Herald TranscriptAug 19 2020, 5:30 PM
Herald added a reviewer: Restricted Project. · View Herald Transcript
rprichard requested review of this revision.Aug 19 2020, 5:30 PM

Rebase this change.