In this patch, we add a helper function getDWARFEmitterByName(). This
function returns the proper DWARF section emitting method by the name.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Paths
| Differential D84952
[DWARFYAML] Add helper function getDWARFEmitterByName(). NFC. ClosedPublic Authored by Higuoxing on Jul 30 2020, 9:23 AM.
Details Summary In this patch, we add a helper function getDWARFEmitterByName(). This
Diff Detail
Event TimelineHiguoxing added a child revision: D84921: [DWARFYAML] Make the debug_aranges entry optional..Jul 30 2020, 9:24 AM Higuoxing retitled this revision from [DWARFYAML] Refactor emitDebugSections(). NFC. to [DWARFYAML] Add helper function getDWARFEmitterByName(). NFC..Jul 30 2020, 10:46 PM Higuoxing added a parent revision: D85003: [DWARFYAML] Add emitDebug[GNU]Pub[names/types] functions. NFC..Jul 30 2020, 11:16 PM Higuoxing marked an inline comment as done. Comment ActionsAddress review comments. Thanks for reviewing! This revision is now accepted and ready to land.Jul 31 2020, 3:42 AM Closed by commit rG760e4f22027c: [DWARFYAML] Add helper function getDWARFEmitterByName(). NFC. (authored by Higuoxing). · Explain WhyJul 31 2020, 5:11 AM This revision was automatically updated to reflect the committed changes.
Revision Contents
Diff 282176 llvm/include/llvm/ObjectYAML/DWARFEmitter.h
llvm/lib/ObjectYAML/DWARFEmitter.cpp
llvm/lib/ObjectYAML/ELFEmitter.cpp
|
I'm not sure this check is really giving us anything. There's a check in the getDWARFEmitterByName that the name is a recognised name (the default case), so I think you can just remove this check here.