This patch replaces call site.... with call base to be more consistent with the rest of the LLVM.
Diff Detail
Event Timeline
Personally, callsite still sounds more natural in some places, but LGTM.
Probably wait a little bit for someone else to see as well.
I think replacing all makes the code hard to understand (because "call base" is just a name of LLVM class)
Personally, I prefer maintaining "call site"
Thanks for the feedback. I think It would make sense to call it "call base" since we are making deductions on the LLVM IR.
I think it doesn't make sense to use IRPosition::callsite... when you want to make deductions about a CallBase.
I'm on the fence on this one. It makes sense when we talk about the instructions, it doesn't really if we talk about the concept, and I don't really want to mix the two wordings.
Let's postpone this for now and you ping it in a week or so, maybe my subconscious mind will have formed a more useful opinion by then.