This patch helps make the Code optional in abbreviations table.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/lib/ObjectYAML/DWARFEmitter.cpp | ||
---|---|---|
100 | Looks unformatted. It is also more common to write in the following way I think: (uint64_t)*AbbrevDecl.Code (i.e. no brackets around the AbbrevDecl.Code) | |
llvm/test/tools/yaml2obj/ELF/DWARF/debug-abbrev.yaml | ||
272 | Could you add a one more DW_TAG_subprogram with the same Code and one more DW_TAG_subprogram after it |
The premerge bot is complaining about several failing tests in ObjectYAML. You should probably investigate those.
Edit to add: oh I see you've spotted that already.
llvm/lib/ObjectYAML/DWARFEmitter.cpp | ||
---|---|---|
100 | Something looks off in this formatting. Did you run clang-format and/or mean (uint64_t)(*AbbrevDecl.Code) perhaps? |
Address comment.
llvm/include/llvm/ObjectYAML/DWARFYAML.h | ||
---|---|---|
55 | Sure, I will leave it as yaml::Hex64 in this patch. I think dumping abbreviation codes in a decimal format has better readability than dumping it in a hexadecimal format. But I'm convincible here :) |
llvm/include/llvm/ObjectYAML/DWARFYAML.h | ||
---|---|---|
55 | I'd change to uint64_t, but separatelly. I think that abbreviation codes in a decimal format would probably look better, because it is just an index? |
I would suggest you keep this as a Hex64 in this patch, and change it to a uint64_t in a separate patch, although I'm not entirely convinced either way whether it should be done at all. Perhaps @grimar has some thoughts?