This patch:
- Adds GpuLaunchFuncToVulkanLaunchFunc conversion pass.
- Moves a serialization of the spirv::Module from LaunchFuncToVulkanCalls pass to newly created pass.
- Updates LaunchFuncToVulkanCalls instrumentation pass, adds initVulkan and deinitVulkan runtime calls.
- Adds bindResource call to bind specifc resource by the given descriptor set and descriptor binding.
- Eliminates static construction and desctruction of VulkanRuntimeManager.
These two are now used as attributes. The convention is to use snake_case for attribute names. So what about naming them as spirv_blob and spirv_entry_point?